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Crestron Fusion Software Add-In for
Outlook Software: Enterprise
Management Platform

Introduction

The Outlook Add-In adds the Crestron Fusion® software room booking wizard functionality
to Microsoft® Outlook software when used with Crestron Fusion installed on-premises. This
feature helps the user find available rooms and resources and sets actions and presets for
meetings or appointments. This document is provided as an aid for installing the Outlook
Web Service (OLWS) and Outlook Add-In (OLAI).

For more information on how to use the Outlook Add-In, refer to the Outlook Add-in
Software User Guide (Doc. 7895).

NOTE: The OLAl is supported only on Crestron Fusion installed on-premises, and not on
the Crestron® hosted service.

Rights

The rights to install the OLAI software depend on the company’s choice of operating
systems and security policies.

Version Compatibility

Crestron Fusion supports Microsoft Outlook versions 2007, 2010, 2013, and Office 365®
software. Each new version of the OLWS and the OLAI supports all previous versions of the
software. No compromise in existing functionality occurs. However, some new features
might not be available if versions are mixed. To avoid any software issues, use the current
version of the Crestron Fusion software. For additional information, contact the Crestron
Fusion Support Group (FSG) at 1-888-273-7876 or e-mail fsg@crestron.com.

Configuration Settings

The configuration settings are held in a text file named OLAIl.config. The configuration file
contains the following settings:

ServerPath: The ServerPath is the URL to the OLWS without the file name.
Language: This is the language to be used in the OLAI User Interface (Ul).
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BookSingle: If the Book Single button is visible, then the value is true or false. BookSingle
allows the user to quickly select a room for a meeting. The user can review the assets and
custom fields for a particular room and bypass the room availability search. Microsoft
Exchange declines the request if the room is busy.

Installation

The OLAI can be installed as a single instance on a PC or deployed to multiple PCs over a
network using group policies. The OLWS needs to be installed before the OLAI on the
on-premises Crestron Fusion server or in a place where the room, schedule, and asset
services have access to the server.

The installation is a two-part process as follows:
1. Install the OLWS server-side software.

Only one version of the OLWS is available. The OLWS installer is not specific to the
32- or 64-bit versions of Outlook. The OLWS runtime automatically switches
between 32- and 64-bit.

2. Install the Outlook Add-in client-side software.

Depending on your version of Outlook, use the 32- or 64-bit installer, and then
select an installation option (Ul assisted or command line).

e The Ul assisted installation is a desktop installation that uses the Previous
and Next buttons to move through the installation. This method is not
suited for production rollouts. Note that BookSingle is not available.

e The command line installation is typically used for automated distribution
installations in large facilities. It includes switches to hide the User Interface
(UI), server URL, and BookSingle activation.

If you encounter any issues when installing the OLWS or OLAI software, contact FSG at
1-888-273-7876 or email fsg@crestron.com.

Outlook Add-In Web Service (Server-Side) Installation
To install the OLWS, complete the following steps:

1. For a client installation, right-click the cmd.exe shortcut, and then click Run as
Administrator.

In the Administrator: Command Prompt window, enter msiexec /i [MSI PATH] into
the command line prompt. [MSI PATH] is the path to the msi file.

Verify that the command is similar to the following:
C:\Temp>msiexec /i c:\temp\OutlookWebServiceSetup_10_x_x.msi

2. From the Welcome window, click Next to open the Select Installation Address
window.

3. Select the Outlook Web Service for Crestron Fusion from the Application Pool
drop-down list.

4. Click Next and then click Next again to open the next window. Please Wait should
be displayed.

5. After the installation is complete, close the Setup panel. An IIS reset is not required.
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6. To verify the URI address of the OLAI, open a web browser on a client or a staging
computer.

7. Enter the following command into the command line prompt:
http://[server name]/fusion/outlookwebservice/addinservice.asmx.

Press Enter.

Verify that the page loaded displays AddinService in the heading.
AddinService Window

AddinService

WANQ SEEraliond M Supported. For b formal definit clipde revedm the Service Descriptio
o Adidaitions ToMeeting
+ GELACUnS

* GetActions! orMesting '

After completing the OLWS installation, install the OLAI. Depending on your version
of Outlook, choose the applicable installation method:

e Outlook Add-in (Ul Assisted 32- and -64-bit) installation
e Outlook Add-in (Command Line 32- and 64-bit) installation

Instructions for these installation methods are described in the sections that follow.

Outlook Add-in (Ul Assisted 32- and 64-Bit) Installation
To install the OLAI, complete the following steps:

1. Depending on your version of Outlook, use one of the following methods to verify
that Outlook is 32- or 64-bit.

e For Outlook 2007, click Help > About. The bit count is displayed.

e For Outlook 2010 and 2013, click File > Help. The bit count is displayed
under the About Microsoft Outlook section.

2. To verify the URI address of the OLWS, open a web browser on a client or a
staging computer.

3. Enter the following command into the browser:
http://[server name]/fusion/outlookwebservice/addinservice.asmx.

4. Press Enter.

5. Verify that the page loaded displays AddinService in the heading.
AddinService Window

AddinService

The following operations are supported. For a formal definiticn, please review the Service Description.

+ AddActionsToMeeting
* GetActions

* GetActionsForMeeting
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6. If your version of Outlook is 32-bit, right-click
RVOutlookAddinSetup_x_x_x_32bit.exe.

If your version of Outlook is 64-bit, right-click
RVOutlookAddinSetup_x_x_x_64bit.exe.

7. Click Run as Administrator to open the Welcome to the Crestron Fusion Add-In
for Outlook Setup Wizard window.

Welcome to the Crestron Fusion Add-in for Outlook Setup Wizard Window
& Setup - Crestron Fusion Add-in for Cutlook =] |

Welcome to the Crestron Fusion
Add-in for Outlook Setup Wizard

This will install Crestron Fusion Add-n for Cutiook version
10.3.1 on your computer.

Itis recommended that you dose all other applications before
continuing.

Click Next to continue, or Cancel to exit Setup.

I Next = |[ Cancel

8. Click Next to open the Ready to Install window.

Ready to Install Window

Setup - Crestron Fusion Add-in for Outlook 3

Ready to Install
Setup iz now ready to begin installing Crestron Fusion Add-in for Outlook on your
computer.,

Click Install to continue with the installation.

< Back l Install I Cancel

9. Click Install to open the Installing window.
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Installing Window

Installing

Please wait while Setup installs Crestron Fusion Add-in for Qutlook on your
computer.,

Finiching installation. ..

|

Cancel |

After the setup process is complete, the Welcome to the Crestron Fusion Add-in
for Outlook Setup Wizard window opens.

Welcome fo the Crestron Fusion Add-in for Outlook Setup Wizard Window

it Crestron Fusion Add-in for Outlook __

Welcome to the Crestron Fusion Add-in for
Outlook Setup Wizard

The ingtaller will guide you through the steps required to ingtall Crestron Fusion Add-in for Dutlook on
Your cornpuker.

WARMIMG: This computer program is protected by copyright law and international treaties.
Unauthorized duplication or distribution of this program, or ang portion of it, may result in severe civil
or criminal penalties, and will be prozecuted to the maximum extent possible under the law.

Cancel | < Back | Iext > I

10. Click Next to open the License Agreement window.
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License Agreement Window

i'-‘%l' Crestron Fusion Add-in for Outlook N

License Agreement

Fleaze take a moment ta read the license agreement now. IF vou accept the terms below, click "
Agree'’, then "MNext". Othemnwize click '"Cancel".

CRESTRON SOFTWARE END-USER LICENSE
AGREEMENT
Rev. 2.0, 01 August 2014

Thank you for using this Crestron end-user software product (the
“Software”). By downloading, installing, or otherwise using the
Software or any portion thereof, or using a Crestron Device on
which the Software is pre-installed, You agree to be bound by

thic End | lcar | icanca A aronmont (tho "ACDERRMERT"Y aarhich
| Do Mot Agree % | hgree

e

-

Cancel | < Back | Ment > I

11. Review the license agreement and then click | Agree.
12. Click Next to open the Outlook Web Service window.
Outlook Web Service Window

{l& Crestron Fusion Add-in for Outlook i
Outlook Web Service

Pleaze provide the URL [without file name]

‘wieb Service Folder

http: //servemame

Cancel | < Back | Mext » I

13. Enter the ServerPath (URL provided by Crestron) in the Web Service Folder field.

Click Next to open the Select Installation Folder window.
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Select Installation Folder Window

i Crestron Fusion Add-in for Outlook 3

Select Installation Folder

The inztaller will install Crestron Fuzsion Add-in for Outlook to the following folder.

To inztall in this folder, click "Mest". Toinstall to a different folder, enter it below or click 'Browse'"

Folder:

C:“Program Files [»86)A\Crestron\Crestron Fusion Add-in for Outlook Browse. .. |
Digk Cost... |

Cancel | < Back | MHext > I

14. To install the OLAI into a folder other than the default folder, enter the desired
location into the Folder field or click Browse to choose a location.

15. Click Disk Cost to open the Crestron Fusion Add-in for Outlook Disk Space
window.

Crestron Fusion Add-in for Outlook Disk Space Window
x

The list below includes the drives you can install Crestron Fusion Add-in for Outlook to, along with
each dnve's available and required disk space.

Yolume | Dizgk Size I Available | Rec «
= I 297GB 189GB 64!
M 458GB 11GB

2p M1GB F4GB

2o 341G TAGE L
=R 573GB 28GB

= 433GB 280GB

==}y MR QAR -
«| ] o

16. Choose a drive to install the OLAI, view the disk space information, and then
click OK.

17. Click Next from the Select Installation Folder window to open the Confirm
Installation window.
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Confirm Installation Window

Confirm Installation

{7 Crestron Fusion Add-in for Outlook o

Click. "Mext" to ztart the installation.

The inztaller iz ready ta inztall Crestron Fugsion Add-in for Outloak on your computer,

Cancel |

< Back | Mest > I

18. Click Next to confirm the installation and open the Installing Crestron Fusion

Add-in for Outlook window.

Installing Crestron Fusion Add-in for Outlook Window

Outlook

ii.‘% Crestron Fusion Add-in for Outlook - =101 x|

Installing Crestron Fusion Add-in for

Crestron Fusion Add-in far Outlook iz being installed.

Flease wait...

Cancel I

< Back | [Hert > |

After the OLAI is installed, the Installation Complete window opens.
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Installation Complete Window

[{% Crestron Fusion Add-in for Outlook 3

Installation Complete

Crestron Fusion Add-in for Outlook has been successfully installed.

Click "Close" to exit.

Fleasze use Windows Update to check for any critical updates to the WET Framework.

Cancel | < Back | Cloze I

19. Click Close to open the Completing the Crestron Fusion Add-in for Outlook
Setup Wizard window.

Completing the Crestron Fusion Add-in for Outlook Setup Wizard Window

=101

Completing the Crestron Fusion
Add-in for Outlook Setup Wizard

Setup has finished instaling Crestron Fusion Add-in for
Outlook on your computer.

Click Finish to exit Setup.

20. Click Finish.

21. To validate the installation, wait at least 5 minutes and then close and reopen
Outlook.
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22. Click Galendar and then click New Meeting to open a meeting.

Calendar and New Meeting

[ Mail

_File. | Home Send /Receive Folder View Adobe PDF
m— -
= ABREEEE]L E
New MNew MNew Today MNext7 Day Work Week [Month|Schedu
|Appointmeny{ Meeting)Items ~ Days Week - View
New GoTo [P Arrange

23. Click the Crestron RoomView® application button to load the Add-In services.

Crestron RoomView

Insert

Format Text

_File_ Meeting
x r% |3 calendar

=
kg Forward ~

Delete Copyto My
Calendar LEOHENOtE

Adtions

Review
Q
E=
===
Crestron

Assistant | RoomView

Irvitation Book Mames Options~

Show

B Y o

Cancel Address Check Response

Attendees

© Invitations have not been sent for this meeting.

To.. | |
I=1 | subject: |
Send
Location: |
Starttime: | Mon 4/6/2015 - [7:00 am = [ Al day event
Endtime: | Mon 4/6/2015 - | [7:30 am

When the Add-In services are loaded, a region list is displayed in the Room

Selection window.

NOTE: The Add-In services may take some time to load.

Room Selection Window Displaying a Region List

Foom Selection | Maeting Properies

Start Time: 21172015 =

7:00:00 AM

EndTime: 21172005 « T000AM |4

293 Regions with Critesa |

Summery | Search Reaut |

- = Search Citena
) Date & Time
Start Time:2/11/2015 7:00:00 AM
- End Time:2/11/2015 7.30.00 AM

Clesr Selected Criteria Clear &I Criteria Find Availsbie Rooms
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Outlook Add-in (Command Line 32- and 64-Bit) Installation

To install the OLAI, complete the following steps:

1.

Installation Guide — DOC.

Depending on your version of Outlook, use one of the following methods to verify
that Outlook is either 32- or 64-bit.

e For Outlook 2007, click Help > About. The bit count is displayed.

e For Outlook 2010 and 2013, click File > Help. The bit count is displayed in
the About Microsoft Outlook section.

To verify the URI address of the OLWS, open a web browser on a client or staging
computer.

Enter the following address into the browser:
http://[server namel/fusion/outlookwebservice/addinservice.asmx.

Press Enter.
Verify that the page loaded displays AddinService in the heading.
AddinService Window

AddinService

The following operations are supperted. For a formal definition, please review the Service Description

» AddActionsToMeeting
+ GetActions

+ GetActionsForMeeting

Depending on the installation type, use one of the following methods to run the
command line prompt as an administrator.

e For aclient installation, right-click the cmd.exe shortcut and then click Run
as Administrator.

e For an automated distribution, locate the prompt and enter the command
in the distribution software. Verify that the account is run as an
administrator.

Enter [EXE path] /[URI Address] /verysilent into the command line prompt to install
the OLAI.

o [EXE path] for 32-bit is RVOutlookAddinSetup_x_x_x_32bit.exe
o [EXE path] for 64-bit is RVOutlookAddinSetup_x_x_x_64bit.exe

o [URI Address] is url=http://[ServerName]/fusion/outlookwebservice

Refer to the table below for information on switches.

Switch Type Description

/bsn This switch activates the BookSingle features and is either true or false.
To enable the BookSingle functionality, add /bsn=true. For example, to
add the /bsn switch type to the [EXE path] command above, enter
RVOutlookAddinSetup.exe /bsn=true.

/silent This switch runs setup automatically with the Ul displayed. Input is
inhibited.

/url This switch sets the path to the Outlook web service.

/verysilent This switch inhibits the Ul and runs setup automatically.
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8. Depending on the installation type, use one of the following methods to run the

installation command.
[ ]

how to run the command.

For a client installation, press Enter at the command prompt.

For an automated installation, consult the manufacturer’s instructions on

9. To validate the installation, wait at least 5 minutes and then close and reopen

Outlook.

10. Click Calendar and then click New Meeting to open a meeting.

Calendar and New Meeting

[~ Mail

File

Home Send /Receive Folder View Adobe PDF
= =
EH B 8 = E =
Mew Mew Today Mext7 Day Work Week |Month|Schedul
Appointmenl Meeting}Items ~ Days Week Z View
GoTo (F] Arrange

11. Click Crestron RoomView to load the Add-In services.

Crestron RoomView

File. Meeting Insert Format Text Review
>[5 T By
x o I == @| 3 BEY I
i Forward - S
Delete Copyto My \Appointment| Schedulingl Crestron Cancel Address Check Response
Calendar LEOHENME Assistant JRoomView J| Invitation Book Mames Options~
Actions Show Attendees
@ Invitations have not been sent for this meeting.
To.. ‘
1
=1 | subject |
Send
Location: ‘
Starttime: | Mon 4/6/2015 - | [7:00 am - | [0 &l day event
Endtime; | Mon 4/6/2015 -| 730 am -

When the Add-In services are loaded, a region list is displayed in the Room

Selection window.

NOTE: The Add-In services may take some time to load.

Room Selection Window Displaying a Region List

Toom Selection | Masting Propanies

SwTime 1V - TO0O0AM EdTme 215 «  73000AM

Clow Slocton | | 4 Ragions | | 4 Rions with ot

Sy | Soarch Fosuk
Search Ciena
& Date & Time.
Stat Tene 2/11/2015 700,00 AN
End Time 2112015 7.30.00 AM

o Splontd e | | Clows A | | i lab looms
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